Excel als Mini-Datenbank

Freitag, 5. Oktober 2007

Auf Arbeit stand eine Aufgabe an, eine Preisliste zu erstellen. Es gibt eine Tabelle, in der die Bauteile drin sind und eine weitere Tabelle in der die Preise stehen. Beide Tabellen haben als gemeinsames Element eine eindeutige Bezeichnung des Bauteils.
Um nun nicht von Hand f√ɬľr jedes Bauteil den Preis heraus suchen zu m√ɬľssen, recherchierte ich kurz im Web und fand auch recht schnell die L√ɬ∂sung f√ɬľr mein Problem. In der Zielzelle muss folgende Formel stehen:
=SVERWEIS(B2;Tabelle2!A3:T222;16;FALSCH)
B2 -> Suchbegriff, in diesem Fall in einer Zelle stehend;
Tabelle2!A3:T222 -> zu durchsuchender Bereich;
16 -> die Spalte deren Inhalt √ɬľbernommen werden soll;
FALSCH -> Es wird kein N√ɬ§herungswert angezeigt sondern nur eine genaue √ÉŇďbereinstimmung mit dem Suchbegriff

iWork ‘05 vs. iWork ‘06 [Update]

Donnerstag, 18. Januar 2007

Nachdem ich noch die Studentenversion von iWork erstehen kann, habe ich die Woche zugeschlagen. Ich hatte ja die alte Version schon, aber die neue soll ja um Welten besser sein. ūüôā
Ich hab die neue Version noch gar nicht angeworfen, da war ich schon mal √ɬľberrascht. Der Installationsprozess dauerte ungew√ɬ∂hnlich lange, also hab ich mal die Dateigr√ɬ∂√ÉŇłe auf der Festplatte angesehen:

iWork 336MB
iWork '06 1,9GB
Da muss sich einiges geändert haben, bei rund sechs mal so viel Speicherbedarf.
Da bin ich ja mal gespannt, auf den ersten Blick konnte ich keine gro√ÉŇłen √É‚Äěnderungen feststellen.

Update:
Ich habe dann noch einmal Monolingual laufen lassen. Monolingual hat dann erst einmal nicht ben√ɬ∂tigte Sprachen und in einem zweiten Durchlauf die nicht be√ɬ∂tigten Dateien f√ɬľr Intel-Macs entfernt. Das Ergebnis:

iWork '06 1,4GB

Ist zwar immer noch ungef√ɬ§hr vier mal so gro√ÉŇł, aber doch deutlich weniger als vorher.

Kleine Tabellenkalkulation f√ɬľr den Mac

Montag, 17. Juli 2006

zu finden unter
http://homepage.mac.com/gotterdamn/
Belegt auf der Platte gerade mal 1,3MB und ist schlank und schnell.
F√ɬľr einfache Berechnungen gerade ausreichend.
Leider sind so n√ɬľtzliche Sachen wie das Kopieren von Formeln mit automatischem relativem Bezug nicht m√ɬ∂glich. Eine kopierte Formel verweist immer auf die urspr√ɬľnglichen Felder.
Einfache Berechnungen wie +, -, *, / sind möglich, wie auch eine Summenbildung einer Reihe von Zellen.
Was noch unterst√ɬľtzt wird ist das Kopieren einer Tabelle in HTML-Format, was zum Erstellen von Webseiten n√ɬľtzlich sein k√ɬ∂nnte, ich aber (derzeit zumindest) nicht brauche.
Was ich dann noch geschafft habe, ist die Software zum Absturz zu bringen, als ich einen Graph erstellen wollte.
Stabil scheint die Software also nicht besonders zu sein.